97 STI RA not selecting gears!!!

Discussion in 'Subaru Impreza WRX Help & advice' started by stira2, Aug 13, 2019.

  1. tekkerchrede

    tekkerchrede V-Limited Member

    Like a loose gearbox or similar. Not saying it is likely, but if it is close to falling off basically.
     
  2. stira2

    stira2 V2 STI RA V-limited, V3 STI RA

    Location:
    North Wales
    No its bolted up tight and can't see anything loose
     
  3. Topper Harley

    Topper Harley V-Limited Member

    Location:
    Westmeath Ireland
    Sounds like clutch clearance issue . Gearbox out time .
     
    • Agree Agree x 1
  4. stira2

    stira2 V2 STI RA V-limited, V3 STI RA

    Location:
    North Wales
    Yay my favourite
     
  5. stira2

    stira2 V2 STI RA V-limited, V3 STI RA

    Location:
    North Wales
    All sorted now, took it for a drive after starting it in gear. Now it's shifting like a dream.
    I think with the weather we've had rain has been managed to get through the bonnet vent and go down the inspection hole on the top of the box.
     
    Last edited: Aug 17, 2019 at 10:54 AM
    • Like Like x 2
  6. Paul92

    Paul92 V-Limited Member

    Location:
    Rutten
    Perhaps some cleaning of the splines on the input shaft and a bit of clutch grease on the moving parts could prevent this. The timing hole cover can harden over time and lose it's snug fitment.

    In which gear did you start the car, and was the clutch operational instantly of after a little drive?
     
  7. stira2

    stira2 V2 STI RA V-limited, V3 STI RA

    Location:
    North Wales
    I've not long since put a 6 speed in and everything that should be greased was, think I'm going to invest in a cover for the hole as its rock solid...

    Started it in second and it freed up after a couple of tries.
     

Share This Page